Skip to main content

FormatDesigner

Möchtest du Daten aus deinem plentymarkets System exportieren? Das geht in zwei einfachen Schritten:

  • Zuerst verwendest du den FormatDesigner, um sogenannte Datenformate zu erstellen. Mit anderen Worten entscheidest du, welche Daten exportiert werden sollen.

  • In einem zweiten Schritt verwendest du den Elastischen Export, um die soeben erstellten Datenformate zu exportieren.

Diese Handbuchseite beschreibt den ersten Schritt. Hier lernst du, wie du das FormatDesigner-Plugin einrichtest, wie du Datenformate erstellst und welche Daten du exportieren kannst.

Der zweite Schritt, d.h. der eigentliche Export, wird im Menü Daten » Elastischer Export vorgenommen. Weitere Informationen zum zweiten Schritt findest du auf der Handbuchseite zum elastischen Export.

1. Plugin einrichten

Finde zunächst das FormatDesigner-Plugin auf plentyMarketplace und füge das Plugin zu deinem System hinzu. Grundlegende Informationen dazu, wie du dein plentymarkets System mit Plugins erweitern kannst, findest du im Plugin-Kapitel.

Plugin aktualisiert?

Plugins werden ständig aktualisiert und verbessert. Prüfe deshalb im Menü Plugins » Plugin-Übersicht » Plugin-Set öffnen, ob du die aktuelle Version des Plugins verwendest, bevor du Datenformate erstellst.

FormatDesigner-Plugin löst das ElasticSync-Plugin ab

Nutzt du noch das ElasticSync-Plugin, um Exportformate zu erstellen? Dieses Plugin wird zukünftig nicht mehr aktualisiert. Wir empfehlen daher, auf das FormatDesigner-Plugin zu wechseln und das ElasticSync-Plugin aus deinem Plugin-Set zu löschen.

2. Format erstellen

  1. Öffne das Menü Daten » FormatDesigner.

  2. Klicke auf Format hinzufügen.

  3. Gib einen eindeutigen Namen ein.

  4. Wähle das gewünschte Format und Feldtrennzeichen.

  5. Klicke auf Speichern ().

3. Format bearbeiten

Sobald ein Format angelegt oder geöffnet wurde, wird die Bearbeitungsansicht des Formats angezeigt. Auf der rechten Seite befindet sich die Auswahl der verfügbaren Datenfelder. Durch einen Klick auf ein Feld wird das Feld auf der linken Seite ergänzt. Nachdem ein Datenfeld hinzugefügt wurde, können weitere Einstellungen vorgenommen werden. Nach dem Speichern ist das Datenfeld im Export enthalten.

Tabelle 1. Einstellungen der Datenfelder
Einstellung Erläuterung

Namen

Namen für das Datenformat eingeben. Der Name erscheint in der Kopfzeile der CSV-Datei.

Verschieben

Über den mit Punkten markierten Bereich links vom Datenfeldnamen können mit gedrückter Maustaste die Datenfelder verschoben werden. Durch das Verschieben legst du die Reihenfolge der CSV-Spalten fest.

Zuordnung

Datenfelder, wie z.B. VariationSalesPrice.price, benötigen eine genauere Zuordnung, da z.B. mehrere Preise für jede Variante vorhanden sein können. Mit der Zuordnung wird ein konkreter Verkaufspreis bestimmt. Um z.B. mehrere Preise zu exportieren, kann das Datenfeld mehrfach zum Exportformat hinzugefügt werden. Bei Datenfeldern, die keine Zuordnung benötigen, ist die Schaltfläche deaktiviert.

Wert ändern

Datenfelder mit numerischen Werten können während des Exports durch verschiedene Aktionen verändert werden. Dabei können beliebig viele Aktionen definiert werden. Diese Aktionen werden nacheinander ausgeführt und manipulieren den Wert je nach Einstellung.

Datenfeld entfernen

Das Datenfeld wird aus dem Format entfernt.

Zum Seitenanfang